Giant Dirt E+1 2017

cncservsys

Finding my (electric) wheels
Feb 18, 2017
9
2
61
South East UK
Thought I would share my experience with you. Bought this bike in Feb online from dealer in Scotland and all was well for a few weeks. Then whilst cycling home one evening all power died and display went blank. Battery charge indicator (Button on battery) pack showed 2 bars when pressed but could not get it to power on again so had to cycle home 8 miles with no assistance! Put the battery on charge next day and retested, still would not power on when pressing the ON/OFF button. Rang the dealer to ask what could be wrong but they said they would need to speak to Giant and being Sat, they were closed. Later that day went out and tried it again and amazingly the display lit up and all looked good. Tried it several times that day and always worked but never took the bike for a ride, just left it unmoved in the greenhouse overnight. Next morning went out to take it for a ride and again it would not turn on. Spoke to dealer again on Monday to update about the fault but they were of no help other than to again say they would speak to Giant. Eventually guy from dealer rang back and asked me to check the connector inside the frame where the cables enter as they had seen a connector come apart when cable tugged accidentally but there was no fault found there. They then though it could be a battery problem, so I agreed to send it back to them to test or replace under warranty. They tried it on another bike but it worked fine. Giant then suggested replacing the LCD Display and the handle bar push button assembly. Awaiting these which will hopefully arrive tomorrow but I don't have much confidence that they will fix the problem!
Anyone else had a similar problem? Bike is immaculate and never been ridden in the wet. Done approx 140 miles. very disappointing!
 
  • Informative
Reactions: LeighPing
D

Deleted member 4366

Guest
My guess is the LCD has condensation in it, which is a killer. did you use it in the rain or leave the bike out in the rain?
 

cncservsys

Finding my (electric) wheels
Feb 18, 2017
9
2
61
South East UK
My guess is the LCD has condensation in it, which is a killer. did you use it in the rain or leave the bike out in the rain?
Well done you were right! But don't think condensation caused the failure as it's never got wet.
Up and running again, happy days!
 

Advertisers