Intermittent fault wisper 806se ....help please?

mermeo29

Pedelecer
May 31, 2020
28
4
So my LCD comes on and where the bars go across showing the current it is hit and miss so when riding the motor is hit and miss? Battery is fine
Any ideas welcome please?
Mel
 

Nealh

Esteemed Pedelecer
Aug 7, 2014
13,385
5,198
58
West Sx RH
Check the motor connector, follow the motor wire from the hub till you come to it. Make sure the two parts are fully together.
Next continue following the motor wire to the controller box, again check all the motor wire phase and sensor connections. Esp look for any discolouration or melting of the thick phase wire bullets/coverings.
 

mermeo29

Pedelecer
May 31, 2020
28
4
Check the motor connector, follow the motor wire from the hub till you come to it. Make sure the two parts are fully together.
Next continue following the motor wire to the controller box, again check all the motor wire phase and sensor connections. Esp look for any discolouration or melting of the thick phase wire bullets/coverings.
 

Nealh

Esteemed Pedelecer
Aug 7, 2014
13,385
5,198
58
West Sx RH
Another possibility worth checking first is the pedal sensor and magnet disc, ensuring the disc is firmly on the BB spindle and doesn't rotate around the spindle by hand also check the gap between sensor head and magnet disc is even and of about 1mm.
 

artspeck

Pedelecer
Nov 21, 2016
63
21
83
Sunderland
I have the answer to your question, finally. I’ve got the same bike with 700 battery.
Meter readout on battery shows fully charged yet the lcd screen shows only one bar.
After 3 weeks watching every video known to man on this subject, I’ve fixed it.
Press all 3 buttons on the lcd screen all at once and hold for a few seconds.
Eventually the screen will show either the number 45, 36 or 24. These readings should match the voltage of the battery. Mine was showing 45 when in fact it needed to read 36 to match the 36 volt battery. Just press up or down to show 36, release all buttons together and as long as it’s still reading 36, switch off at the battery, wait a few seconds, switch back on and it will now show full charge at the display. I’m absolutely euphoric to have this sorted, something no professional could tell me, not even Wisper tech dept could tell me. Good luck, and please let me know if this helped. Art
 

Related Articles

Advertisers