KT 890 LED panel dont show speed

maggy.apo

Pedelecer
Jul 16, 2020
25
1
Finishing my installation of this Ekit from cyclotricity (250 front hub)
I just realize my LED panel dont show any info of speed at any moment
I set up my LED exactly like in this video (only difference is I have a 29/700C wheel)
but my speedodemeter never moves
PAS work and I can feel is different in the 3 different modes, so I imagine my motor is"feeling" the speed, but not showing on the led panel
there is something I need to change in that setup?
Is ok if I keep using the bike without speed info?
Thanks
 

maggy.apo

Pedelecer
Jul 16, 2020
25
1
nothing more than the things on my kit
(front hub, PAS, controller, battery)I though I read somewhere, the front hub a sensor inside, isnt that true?
 

vfr400

Esteemed Pedelecer
Jun 12, 2011
4,713
1,658
Basildon
You haven't shown what you have and what you've done, so how can anyone help. Logically, you need a speed sensor connected to the white wire.
 

maggy.apo

Pedelecer
Jul 16, 2020
25
1
Sorry vfr400, I am super new in this
I just have all the items from my kit installed like this diagram
37260
I have a LED panel (KT890)

I dont have any white cable, just cable like this

37261

I dont have a real photo atm
Do I need a extra pieceto get that reading?
Thanks for your help
 

vfr400

Esteemed Pedelecer
Jun 12, 2011
4,713
1,658
Basildon
The white wire is the ninth wire in the 9-pin connector. If your motor has a speed sensor, the signal is carried by that wire. if it's a DD motor, the controller can pick up the signal from one of the hall sensors.

There is usually a setting in the LCD for how many pulses per revolution to set the speed correctly, but you don't have an LCD. I think there is some way to set parameters with that LED control panel, but I don't know hoe.
 

maggy.apo

Pedelecer
Jul 16, 2020
25
1
how do I know if my motor have that?
I only have the led panel :(
I imagine the system have some "way" to calculate the speed because I imagine thats the way the controller will know the speed to stay inside the restricted rules, right?
there is no way to display speed in that speed bar in the led panel?
 

maggy.apo

Pedelecer
Jul 16, 2020
25
1
oh boy, every time I asked something to them they never give clear info and take too many days, I will ask
But if someone around here have similar or same kit and knows about this it will be highly appreciate
 

PC2017

Esteemed Pedelecer
Sep 19, 2017
621
75
Scunthorpe
You would need to ghost some settings from an LCD3 via a pricey and rare cable if I was to hazard a guess, the guys at cyclotricity should really of done this for you if the are UK based, using your wheel size.

Either buy an after market KTLCD3(or better) and check your wiring connectors if they are waterproof then you'll be looking at £25-30 less if JST OR [and this is you best option imo]

Buy a separate bike computer from ebay or the local bike shop, cheapest on ebay £8.00 then you have to install it according to instructions and you'll have a small speedO LCD - I see most LED ebikes with this setup as the ghosting setting option is to hard for most bike shops to be bothered with.

Edit or get a phone mount for your bike and use a speedO app
 
Last edited:

Nealh

Esteemed Pedelecer
Aug 7, 2014
11,097
4,277
57
West Sx RH
The hub in the pic is a D/D hub, if it is a 250/1000 dual hub then it doesn't support any old KT display and uses a customer custom version. We have had enquiries before about these kits and similar issues, the LCD3 from them is more expensive for that reason.
 

maggy.apo

Pedelecer
Jul 16, 2020
25
1
37265

thats my hub, 250W
well I thought I was doing something wrong with the settings of the led panel and because that I wasnt able to see any speed on that little bar on the led panel, but if this a feature not available with my pieces from this kit and everything will work the same (because I imagine still the wheel knows or its able to aprox calculate speed to cut when I reach the limit) I will not even bother to ask to cyclotricity, I just wanted to check "this is normal" I will definetly just use my phone if I need to see my speed while I ride the bike
 

Nealh

Esteemed Pedelecer
Aug 7, 2014
11,097
4,277
57
West Sx RH
Ok thanks for the proper pic it is a geared hub, in #5 you posted an incorrect pic of a D/D hub system so one can only surmise.

KT 890 user manual.

The only settings seem to be by pressing on/off and mode at the same time for a few seconds.

The display should pick up a speed reading via the hub motor but only if it has a 9 pin motor connector and if the ninth wire is used.
 
Last edited:

PC2017

Esteemed Pedelecer
Sep 19, 2017
621
75
Scunthorpe
TBF I was looking at the cheapest speedO bike comp and there's a cool wireless one for £7.50 free p&p

Edit front hub sweet - the best option imo - just watch out for nasty loose gravel or stone chippings at traffic lights, at full PAS set offs you'll wheel spin like crazy with them tyres!
 

vfr400

Esteemed Pedelecer
Jun 12, 2011
4,713
1,658
Basildon
Here's what I'd do. Open the controller, switch everything on, then test the voltage where the white motor wire is soldered while you spin the wheel. If you get one pulse on or off with 5v per rotation, you have a speed sensor in the motor, but the controller settings aren't picking it up. In that case, there's not much you can do except get an LCD.

If there's no pulse, note whether the white wire is held at 0v or 5v. Buy a £2 cycle computer from Ebay and cut off the head unit. Join one of the sensor wires to the white wire and the other to any 5v position if the white wire was measured as 0v or any ground if it measured 5v. Install the sensor and pray that the speed display works. Before installing, you can test it by passing the magnet back and forth over the sensor by hand t see if you get a response from the speed display.
 
  • Like
Reactions: Bikes4two