motor problem

gazza19

Pedelecer
Aug 22, 2020
158
3
hi i have just bought a seago power electric folding bike it all lights up but as soon as i connect the nine pin plug from the motor to the connector that goes to the controller it shuts
all power off can anybody tell me why it is doing it and how to test the motor to see if its that is causing the problem many thanks in advance
 

Nealh

Esteemed Pedelecer
Aug 7, 2014
14,229
5,510
58
West Sx RH
Try connecting the 9 pin motor cable to controller before you power up then switch on the power, then see if it all works.
 
  • Like
Reactions: gazza19

gazza19

Pedelecer
Aug 22, 2020
158
3
Try connecting the 9 pin motor cable to controller before you power up then switch on the power, then see if it all works.
done that and nothing works dosnt power up when i do it that way when it goes i have to undo the battery then reconnect it and if the connector from the motor is not connected to the connector that goes to the controller then it will all power up again
 

Nealh

Esteemed Pedelecer
Aug 7, 2014
14,229
5,510
58
West Sx RH
Back to the vendor then.
 

Nealh

Esteemed Pedelecer
Aug 7, 2014
14,229
5,510
58
West Sx RH
Possible it is damaged coming out of the axle or a rogue cable wired incorrectly.
Still a new bike it is warranty/vendor to sort out.
 

vfr400

Esteemed Pedelecer
Jun 12, 2011
9,822
3,922
Basildon
You need to test with a meter to see where the problem is. If you test the motor through the cable first, you'll know whether a new controller will sort it out.
 

gazza19

Pedelecer
Aug 22, 2020
158
3
You need to test with a meter to see where the problem is. If you test the motor through the cable first, you'll know whether a new controller will sort it out.
can you please tell me how to test it pal as im still learning all about ebikes wish i was as good as you and neath or one of you live closer to halifax lol
 

gazza19

Pedelecer
Aug 22, 2020
158
3
Pull the controller out and show us photos that clearly shows the individual wires and connectors. Like this:


not this:
 

Attachments

Nealh

Esteemed Pedelecer
Aug 7, 2014
14,229
5,510
58
West Sx RH
How are the lights wired ? Try disconnecting them try again.
 

gazza19

Pedelecer
Aug 22, 2020
158
3
How are the lights wired ? Try disconnecting them try again.
i will try that thanks but why would the motor make a thud and knock all the power off the lights are on connectors will try disconnecting the brakes too
 

gazza19

Pedelecer
Aug 22, 2020
158
3
Do you have a meter to test it with?
what sort of meter pal i have disconnected the lights pedal assist and brakes connector from the controller then when i connected the motor it made a thud and jolted a little bit but knocked the whole power of
 

vfr400

Esteemed Pedelecer
Jun 12, 2011
9,822
3,922
Basildon
what sort of meter pal i have disconnected the lights pedal assist and brakes connector from the controller then when i connected the motor it made a thud and jolted a little bit but knocked the whole power of
A digital multi-meter, like this. Without one, you've got virtually no chance of sortin your bike:
 

gazza19

Pedelecer
Aug 22, 2020
158
3
A digital multi-meter, like this. Without one, you've got virtually no chance of sortin your bike:
hi yea i do have one of them pal so if you could guide me on what to do would be a great help like i said on last post i disconnected the brakes light and pedal assist and it still did which leads me to think that it is either the motor for sure or the controller
 

Related Articles

Advertisers