Tongsheng TSDZ2 no pedal assist.

Les186

Finding my (electric) wheels
Apr 18, 2020
5
4
Tongsheng TSDZ2 kit with VLCD6 display fitted to Orbit tandem. Battery is Hailong 36V 13A. Unfortunately there is no pedal assist! Connected the throttle and the motor sprung into life, however still no pedal assist. So is it the torque sensor or the controller or can anyone suggest something else? Could it be the wrong firmware, e.g. set up for a 48V battery? I will contact the Chinese supplier, the kit came via Aliexpress.
 
  • Like
Reactions: Bikes4two

Bikes4two

Pedelecer
Feb 21, 2020
177
81
Hi Les,
  • There's a few possible lines of investigation mention in the post HERE
  • The Hailong battery you are using - you didn't mention if it was a new one or used from somewhere else?
  • Either way, do you have a way of monitoring the voltage at the time you engage 'walk assist' and ask for normal 'assist'?
  • I say this, as if there was a battery problem of some sort, you'd see the monitored voltage drop right off. T
  • If the battery is a 'doner' from else where and it was allowed to discharge too much, then the battery might not recover enough to power the motor.
  • I have a little voltage monitor that plugs into the charging port - I've just plugged it in and the battery voltage drops by 0.1v when 'walk assist' comes on.
  • Another source of information is the endless-sphere.com forum. If you search as I have just done for 'TSDZ2 Torque Sensor', there's a lot of 'hits' to follow up on.
  • See this endless sphere posting as an example of what worked for someone with a problem similar to yours - link
  • And there is a github page for wider reading HERE
  • Do please keep us all informed on progress with resolving the problem, especially the response of the supplier.
  • Many TSDZ2 buyers like to go for a UK supplier for the comfort of 'after sales' support - laudible of course but it comes at a price, a price worth paying if you're not one to delve into the mechanics of these things when they misbehave.
 
Last edited:

Bikes4two

Pedelecer
Feb 21, 2020
177
81
There is a question around whether a faulty speed sensor will give problems (as in no assist) - opinions vary - so I've just been out on my TSDZ2 (VLCD6, 36V, 250W running OSF) to see what happens if I remove the wheel magnet:
  • The system boots up and I can pedal off and assistance kicks in
  • The display DOES NOT show any speed (as you'd expect)
  • After pedalling a few 10's of metres, the assist stopped and error E08 showed on the display.
  • Error E08 is Faulty speed sensor or magnet too far away.
I powered down from the display and replaced the magnet:
  • The system boots up and on pedalling, the speed is shown but still no assist
  • Powered down again FROM THE BATTERY SWITCH and this time I left power off for about a minute
  • On powering back up, all was good ie speed shown on the display and assist working
Whether this is the same for those run stock firmware, I couldn't say.

So Les, when you pedal off on the tandem, are you getting a speed on the VLCD6?
 

Les186

Finding my (electric) wheels
Apr 18, 2020
5
4
Thanks for the posts. The battery is new. I stuck my multimeter probes in the charging socket and got 41V. When I engaged "walk assist" the voltage fell to 39V then rose to about 40.5V. I tried pedalling and the voltage remained at 41V so no assist as expected. Thanks also for the links, I'll have a look.
 

Les186

Finding my (electric) wheels
Apr 18, 2020
5
4
I forgot to mention that the display does register speed and distance. When I first tried a wee pedal the magnet was in the wrong position and no speed was registered but I didn't see any error codes.
 
  • Like
Reactions: Bikes4two

AndyBike

Pedelecer
Nov 8, 2020
176
81
I'd this the other day. Started off and felt zero assistance, and thought oh God.

Then I noticed it was switched off :rolleyes: silly me.
 

Les186

Finding my (electric) wheels
Apr 18, 2020
5
4
I got a reply from the supplier (BOLLFIT Ebike Store) requesting a video to show my problem? As somebody said perhaps a video of me at the top of a hill all red in the face and sweating because I don't have pedal assist.
 
  • Like
Reactions: Bikes4two

Bikes4two

Pedelecer
Feb 21, 2020
177
81
  • That should be a laugh then Les - getting the video that is!
  • I should think that if you raise the back wheel off the ground (suspended from a garage roof beam on a piece of rope or similar?) take 3 video clips of
    1 - the VLCD6 display showing the screen with battery bars and being able to select different assist levels and then someone to turn the wheel with the speed sensor on it to show that speed is being 'seen' by the system
    2 - a shot of the chainwheel going around whilst someone activates 'walk assist' and audio clear enough that the motor can be heard running
    3 - another shot of the chainwheel and cranks whilst turning the pedals but with audio pickup sufficient to demonstrate that the motor IS NOT running. Even if audio is poor, the video will show that when you stop pedalling then the chainwheel also stops immediately. If the motor where running, the chainwheel normally runs on for a further second or so.
  • be sure to mention that you don't have ebrakes fitted and what you'd tried with the throttle.
  • sounds simple - NOT! - anyway, good luck with it all. Hopefully the seller won't want you to return the motor to China at your cost.
  • I once had a problem with an Android car stereo touch screen - I had to video that - they then sent me a replacement touch screen which I had to replace myself - just as well my professional background was in electronics!
  • How are you as TSDZ2 dismantling?
 

Les186

Finding my (electric) wheels
Apr 18, 2020
5
4
Thanks for the advice. I had a first stab at making a video showing most of your points but it was too large to send even after compressing the files. I have now sent two videos, one "assist" and the other "walk". I'm not sure about the quality of the videos - Steven Spielberg I am not!
 
  • Like
Reactions: Bikes4two

vidtek

Esteemed Pedelecer
Mar 29, 2015
289
139
71
Bournemouth BH12
Thanks for the advice. I had a first stab at making a video showing most of your points but it was too large to send even after compressing the files. I have now sent two videos, one "assist" and the other "walk". I'm not sure about the quality of the videos - Steven Spielberg I am not!
Use a free online cloud storage like dropbox or Mega and just send them a link.
 
  • Like
Reactions: Bikes4two