Help! TSDZ2 connection error with ST-LinkV2

gazellig

Just Joined
Sep 2, 2021
2
0
Hi All,

I'm loving my TSDZ2 conversion of my Gazelle bike, but I was curious how it would ride with the 'emmebrusa' Open Source firmware.

I've made the programming cable, installed the ST software and drivers, but when I connect the ST-LinkV2 to the motor and try to read the settings I get this error: 'Cannot communicate with the device!'
I've checked the pinout and connections multiple times and they're correct.

Any idea what the issue could be? The error message gives some clue but I don't know what that means.

Also, if this is not the right forum to post this question, please redirect me.

thanks!

43796
 

TJS109

Pedelecer
Sep 29, 2017
85
41
74
Glos
There are a couple of possibilities.
Have you connected the reset lead ? I found mine worked best with the reset line not connected.
It is really important that the leads to between the plug and dongle are as short as possible .
It is also possible that the dongle is faulty, if you run the software with the dongle not plugged in do you get a message saying that it cannot connect with the tool?
 

gazellig

Just Joined
Sep 2, 2021
2
0
There are a couple of possibilities.
Have you connected the reset lead ? I found mine worked best with the reset line not connected.
It is really important that the leads to between the plug and dongle are as short as possible .
It is also possible that the dongle is faulty, if you run the software with the dongle not plugged in do you get a message saying that it cannot connect with the tool?
Thanks for you reply TJS, appreciated.
I have also tried it without the reset line, but I get the same error message. The leads between the plug and the dongle are short, 10 cm. I too thought it could be the dongle so I bought another one which gave me the same error message.
If I run the software without the dongle, I get the message saying it cannot connect with the tool, as you say. When the dongle is connected to the computer, I get the 'cannot connect to device' message, whether or not the dongle is connected to the motor as well.

Any other ideas?
 

TJS109

Pedelecer
Sep 29, 2017
85
41
74
Glos
10 cms is too long, I made the same mistake. try to get them as short as you can 2-3 cms say