Haibike Yamaha - battery replacement options

Izzyekerslike

Esteemed Pedelecer
Apr 3, 2015
454
415
Leeds, West Yorkshire
I'm in Australia, I ordered the battery from China. I charged it up a few times only. Back when it happened, I didn't know if it was the motor or the battery that was at fault. Its only that I found your posting that I realised we have the same problem. Screen shows all of its display for a few seconds, then turns off. I cant send it back, so I am stuck with it (impossible to send Li batteries, no one in Australia will handle big Li batteries)

Aaron
Hi Aaron,
Just a thought that you may have been very unlucky !
My "pattern" Yamaha battery is still working fine and has done for the last 18 months.
At the moment you have a bike that's useless and if you are certain it's the battery the only possible way forward I can see is to bite the bullet and buy another Chinese battery.
I realise it a gamble but if it comes off you'll be a very happy rider.

All the best.
 
Last edited:
  • Agree
Reactions: chris_n

doomo

Pedelecer
Oct 6, 2016
31
7
46
Cambs
It might be worth opening it up and seeing if its the fuse thats blown, although your symptoms seem a little different as mine wouldnt fire up at all.
 

Graham101

Pedelecer
Sep 1, 2018
30
0
Hi all, I'm after some advice on replacement batteries for a Haibike sduro allmtn rc 2015 model as the battery BMS has given up. Trying a battery from a local shop shows the bike motor / display works so a new battery is required......but not £750 price!

I ordered one of these as it looked a perfect match
https://www.batteries4pro.com/de/Mobilitat/Elektro-bike/3,15269-36v-li-ion-13ah-akkutyp-yamaha-winora-y280-x-haibike-sduro-3052351243985.html

It arrived but doesn't work, nothing on display and 17v DC on +/- pins. I also took it to local bike shop and it didn't work on their shop bike, so it goes back.
I called allbatteries in UK and they say they don't have anything compatible with my bike.
The battery I have shows the following info..
36v 11ah 400w ( would like bigger capacity,)
PASB2, B94-20 & X94-20.

What's a compatible battery for my bike, hope someone know.....
 

doomo

Pedelecer
Oct 6, 2016
31
7
46
Cambs
Looks like the right battery to me It says 36 V so should be the right one but that 17v reading suggests it is faulty and is why it doesnt work in the bike.
 

Izzyekerslike

Esteemed Pedelecer
Apr 3, 2015
454
415
Leeds, West Yorkshire
Hi all, I'm after some advice on replacement batteries for a Haibike sduro allmtn rc 2015 model as the battery BMS has given up. Trying a battery from a local shop shows the bike motor / display works so a new battery is required......but not £750 price!

I ordered one of these as it looked a perfect match
https://www.batteries4pro.com/de/Mobilitat/Elektro-bike/3,15269-36v-li-ion-13ah-akkutyp-yamaha-winora-y280-x-haibike-sduro-3052351243985.html

It arrived but doesn't work, nothing on display and 17v DC on +/- pins. I also took it to local bike shop and it didn't work on their shop bike, so it goes back.
I called allbatteries in UK and they say they don't have anything compatible with my bike.
The battery I have shows the following info..
36v 11ah 400w ( would like bigger capacity,)
PASB2, B94-20 & X94-20.

What's a compatible battery for my bike, hope someone know.....
Hi, You must have spoken to the wrong person at allbatteries.co.uk.
I have a 2015 haibike allmtn rc and have had one of their 468watt batteries working perfectly for almost 2 years now. They have them on their website.

http://www.allbatteries.co.uk/electric-bike-battery/yamaha-motor-36v/haibike/sduro-allmtn-rc-aml9144.html
 
  • Like
Reactions: Graham101

Graham101

Pedelecer
Sep 1, 2018
30
0

Attachments

Graham101

Pedelecer
Sep 1, 2018
30
0
Hi, You must have spoken to the wrong person at allbatteries.co.uk.
I have a 2015 haibike allmtn rc and have had one of their 468watt batteries working perfectly for almost 2 years now. They have them on their website.

http://www.allbatteries.co.uk/electric-bike-battery/yamaha-motor-36v/haibike/sduro-allmtn-rc-aml9144.html
Thanks Izzy
Do you have the old battery just to check the numbers are the same as mine?
Love the bike but not good it's taking ages getting a battery and no idea why the old one failed :(

Graham
 

Izzyekerslike

Esteemed Pedelecer
Apr 3, 2015
454
415
Leeds, West Yorkshire
That's what I thought, hope it's faulty and it's not me going mad.
If I checkout Amazon allbatteries sell there also on this link...

https://www.amazon.co.uk/NX-Li-Ion-electric-battery-Yamaha/dp/B01LZ6XOPO/ref=mp_s_a_1_4?ie=UTF8&qid=1539801411&sr=8-4&pi=AC_SX236_SY340_FMwebp_QL65&keywords=yamaha+36v+battery&dpPl=1&dpID=31H-twc7yFL&ref=plSrch

Numbers on the back of the Original battery are B94-20.
If you buy it from Amazon and it's not suitable they refund so nothing to lose.

Izzy

So is this compatible with my battery?
It shows B94.......20 & x92......20 my battery just missing the middle numbers!

Graham
Thanks Izzy
Do you have the old battery just to check the numbers are the same as mine?
Love the bike but not good it's taking ages getting a battery and no idea why the old one failed :(

Graham
 

Graham101

Pedelecer
Sep 1, 2018
30
0
Thanks Izzy for the confirmation. I'll speak to allbatteries once I get my refund for the faulty unit from batteries4pro.

Graham
 

Frarig

Just Joined
Nov 28, 2016
4
0
52
Cornwall / South Korea
Hi. Just bought a 36V, 17AH battery for my 2015 AllMtn RC from electropapa.com (which seems to be the online arm of a German company). Battery arrived in good time but when I put it on the bike and switch on, nothing happens apart from all symbols on the control panel light up for a few seconds and then it switches off again (goes back to just showing the time). I put the battery on charge overnight but the problem is the same. Today I used a multimeter across the + and - slots on the battery and got a reading of 2.74 V. Battery knackered, or am I possibly doing something idiotic?
Thanks for any suggestions you might have.
Fraser
 

Nealh

Esteemed Pedelecer
Aug 7, 2014
11,180
4,313
57
West Sx RH
Batteries with a switch have to be switched on to get a reading. Also some may need mounting on the bike to allow a voltage reading, in which case if careful you could rig the battery up so as to enable you to get an out put reading.
 

chris_n

Esteemed Pedelecer
Apr 29, 2016
575
364
58
Austria , Niederau or NE England
You can only read the voltage on a Yamaha battery with the battery on the bike ans switched on. Be careful of the third terminal with your multimeter, if you probe it to the wrong side you will kill the electronics! (With an OEM BMS)
 

Frarig

Just Joined
Nov 28, 2016
4
0
52
Cornwall / South Korea
You can only read the voltage on a Yamaha battery with the battery on the bike ans switched on. Be careful of the third terminal with your multimeter, if you probe it to the wrong side you will kill the electronics! (With an OEM BMS)
Thanks chris_n and Nealh -- I'll have to figure out a way to get a voltage reading without frying it. Would you say the control panel lighting up and then dying is symptomatic of a bad battery, or could it be any number of things?
Fraser
 

chris_n

Esteemed Pedelecer
Apr 29, 2016
575
364
58
Austria , Niederau or NE England
It is symptomatic on no communications between the battery and the display. It is possible that dirty connections can cause this but usually it is the battery that is at fault.
Does the original battery work?
 
  • Agree
Reactions: Nealh

Nealh

Esteemed Pedelecer
Aug 7, 2014
11,180
4,313
57
West Sx RH
Have to agree with Chris looks kike a coms or connection issue.
However if battery voltage is bad then looks like a battery issue.

Do you still have the old battery ?
 

Frarig

Just Joined
Nov 28, 2016
4
0
52
Cornwall / South Korea
It is symptomatic on no communications between the battery and the display. It is possible that dirty connections can cause this but usually it is the battery that is at fault.
Does the original battery work?
I had to leave the original in Korea when I shipped the bike back to UK so unfortunately I have nothing to test with. The terminals look clean, but I'll give them a polish and see if that helps.

I realise now that this same problem has been experienced by a couple of other posters and it appears to have been the battery in both cases. I've written to the site I bought it from and hopefully they will play nice! Thanks for your help, chris_n.
 

chris_n

Esteemed Pedelecer
Apr 29, 2016
575
364
58
Austria , Niederau or NE England
Have to agree with Chris looks kike a coms or connection issue.
However if battery voltage is bad then looks like a battery issue.
You don't get actual voltage until the battery is on the bike and turned on. I have an extender battery on mine, if I measure the voltage it will increase when I turn the battery on.
Also worth noting on the OEM battery if you try and put a load on (maybe a lamp) with the battery not switched on you will kill it.
 

Related Articles

Advertisers