LCD S866 + Brainpower controller

Spinnanz

Pedelecer
Feb 18, 2019
40
12
Even with the white speedo sensor wire connected, I've been unable to get the speedo to work unless the controller is powering the motor.

These controllers will work with or without hall sensors, although e7 will be displayed if the halls are not connected. Without halls the motor will be noisier under acceleration. When up to speed there is barely any difference.
 

tippy56

Just Joined
Feb 15, 2020
1
0
The controller has throttle and PAS/1:1 connection make sure you have used the correct connection as per your link, also if you have fitted a PAS sensor/disc that wasn't supplied you do have to make sure the wire sequence matches. A non supplied PAS may not have the correct connector attached so don't just assume it would fit. China controllers and ancillary's are not standard across the various manufacturers, not all wire colours will match so you simply have to match wire sequence, so 5V to 5V , Gnd to Gnd & signal to signal.
On the controller 5V will be Red or Brown, Gnd will be Black , signal White or any other random colour on a PAS colours will often be like wise.
Often it involves replacing end connectors and changing the wiring order to match that of the controller connector.
male connector on 1.1 connector pas connector also male,no good
 

brayd0715

Just Joined
Apr 8, 2020
2
1
hello my name is bryan I am new to this I have hooked up the controller and display along with power and hall and throttle but I can only get wheel to spin when the green wires are connected if i push throttle while the are connected it goes into reverse
please help
 

Spinnanz

Pedelecer
Feb 18, 2019
40
12
hello my name is bryan I am new to this I have hooked up the controller and display along with power and hall and throttle but I can only get wheel to spin when the green wires are connected if i push throttle while the are connected it goes into reverse
please help
The green wires are only connected when setting the motor direction. In normal use, the green wires will be disconnected.

Disconnect the green wires and set the controller to 3 and and reconnect the green wires.

The motor will power up. If the motor turns the wrong way, disconnect the green wires until the motor stops and then reconnect the green wires. The motor should now turn the correct direction. Disconnect the green wire. Direction is now set. Now try your throttle.
 

brayd0715

Just Joined
Apr 8, 2020
2
1
The green wires are only connected when setting the motor direction. In normal use, the green wires will be disconnected.

Disconnect the green wires and set the controller to 3 and and reconnect the green wires.

The motor will power up. If the motor turns the wrong way, disconnect the green wires until the motor stops and then reconnect the green wires. The motor should now turn the correct direction. Disconnect the green wire. Direction is now set. Now try your throttle.
Thank you I figered it out and now is working
 
  • Like
Reactions: Spinnanz

Jejeraume

Just Joined
May 11, 2020
3
0
Hello everybody,

I've bought a controller 866C which is for 24V 250W e-bike to fit in a pedelec motor. I've cut some unuse wire ( that was an error). And I cut 1 of the 2 green wire.
So I can't learn the phases. Does anyone have photos from this controller or can say me where go the second green wire goes (5V or GND)?

Thanks !

35324IMG_20200511_202318.jpg

IMG_20200511_202336.jpg
 

waszlavik

Just Joined
May 22, 2020
3
0
Hi everyone,
I am Miklós Waszlavik from Hungary. My brother's pedelec is broken. They are no longer manufactured or repaired. I ordered an s866 lcd with controller and a kt v 12 L pas sensor. At first the pas didn't work but this was easy to fix. My questions are: How can I set on lcd (without switch off) the zero torque? In non zero mode, at what speed does the engine start? Thanks for yur help.
 

Attachments

waszlavik

Just Joined
May 22, 2020
3
0

Attachments

Jejeraume

Just Joined
May 11, 2020
3
0
Hi everyone,
I am Miklós Waszlavik from Hungary. My brother's pedelec is broken. They are no longer manufactured or repaired. I ordered an s866 lcd with controller and a kt v 12 L pas sensor. At first the pas didn't work but this was easy to fix. My questions are: How can I set on lcd (without switch off) the zero torque? In non zero mode, at what speed does the engine start? Thanks for yur help.
What do you mean for set the zero torque ? I have a motor in frame, so can't have the right speed on lcd.
 

Gavin Denning

Just Joined
May 21, 2017
1
0
64
Harrogate
I have S866 display and the brake warning icon comes on after 3 seconds power up, with brake wire connected or not and it will only run with learning wires connected. Anyone any ideas. Thanks
 

Joseph

Just Joined
May 31, 2020
1
0
Hello I have the bike Sheng milo fat tire 4’Mx 20 with lcd s866 500w motor 48 v 15ahm is possible someone tell me one good combo programming For long distances I need it because I make delivery many thanks
 
Last edited:

Advertisers